Problem z *.rmvb

Tematy ogólneOprogramowanie
Oprogramowanie dla Linuksa.

Problem z *.rmvb

Postprzez Kochaniak » 20 sie 2007, 00:46

Witam!

Pclos jest moim 3 linuksem w ciagu 3 dni.

Poprzednikami były Mandriva Xtreme i Ubuntu 6.10, najbardziej do gustu przypadl mi jednak PCLinuxOS 2007.


Zainstalowalem z LiveCD, zainstalowalem spolszczenie, pobawilem sie troche i poprobowalem, az w koncu przyszedl czas na relaks :smile:

Posluchałem sobie muzyki w Amaroku i poczytalem w necie o innych dystrybucjach linuksa, kiedy mi sie znudzilo postanowilem sobie obejrzec film!


Wyłączylem przegladarke, Amaroka, znalazlem plyte i wsadzilem do napedu.
Plytka pojawila mi sie na pulpicie, otworzylem wybralem folder z filmem i klik prawym,
Otworz w: / KMPlayer - - -> sam dzwiek.
No nic trudno sprobojemy czegos innego,
Otworz w: / MPlayer - - -> jakis error i dzwiek, bez obrazu.

Muszę dodać iż film jest w formacie *.rmvb


Obrazek


Jestem noobkiem w swiecie linuksa :oops: i chcialbym sie dowiedziec jak pobrac ten kodek i jak go zainstalowac.

Przepraszam jesli taki lub podobny temat byl juz poruszony na forum. :oops:




Z góry dziękuje Kochaniak
Kochaniak
 
Posty: 13
Lokalizacja: Warszawa
Punkty reputacji: 0

Reklama

Postprzez zetha » 20 sie 2007, 09:59

Zainstaluj pakiet win32codecs - jest dostępny w repozytorium, lub zestaw kodeków ze strony mplayera. W pierwszym przypadku znajdą się one w katalogu /usr/lib/win32 i aby np. kaffeine widział kodeki - trzeba zmienić w parametrach silnika xine w opcji decoder ścieżkę dostępu na /usr/lib/win32 lub zmienić nazwę katalogu win32 na codecs. Podobnie z kodekami ze strony mplayera - po rozpakowaniu wkleić do /usr/lib/win32 ew./usr/lib/codecs. To tyle :lol:
zetha
 
Posty: 65
Lokalizacja: Ełk
Dystrybucja: PCLinuxOS 2013
Środowisko graficzne: KDE
Punkty reputacji: 0

Postprzez gela1981 » 20 sie 2007, 15:13

Albo zainstaluj RealPlayer ,jest w repozytorium
gela1981
 
Posty: 19
Lokalizacja: Bukowiec M-cz
Punkty reputacji: 0

Postprzez Kochaniak » 20 sie 2007, 17:36

Zrobione, dzieki wszystkim za pomoc :D
Kochaniak
 
Posty: 13
Lokalizacja: Warszawa
Punkty reputacji: 0

Postprzez pcAsterixos » 21 wrz 2007, 10:07

eee....a ja mam ciekawszy problem.....stało sie cos dziwnego...po zainstalowaniu PCLINUXOSa zgrałem sobie mój ulubiony film na dysk włączyłem i działało no problem (m. innymi dlatego wybrałem Pclinuxosa a nie srubuntu że bez dociągania czegokolwiek działały mi wszystkie formaty) po dwóch tygodniach używania pclosa postanowiłem znów sobie włączyć ulubiony filmik ....i zdziwienie bo nie chce się włączyć :shock: koffeine wyrzuca taki monit :
09:50:10 AM: input_file: Permission denied: >/mnt/hdb6/OptM/Spirited Away /spirited away.DVD-Rip-WS- (Xvid).avi<
09:50:10 AM: xine: found input plugin : file input plugin

zdziwienie było tym większe że jak się później okazało żaden z wcześniej oglądanych na Pclosie filmów nie chce się włączyć i kończy się właśnie takim komunikatem próba jego włączenia....
jak myślicie co na to poradzić....dodam ze doinstalowałem sobie chyba już wszystkie dostępne przez Synapticka stery....ale chyba nie oto chodzi....
(dygresja: międzyczasie tworzyłem pliki tekstowe które po ponownym uruchomieniu pclosa również nie chciały się załadować i wyskakuje mi komunikat że pliki nie istnieją ...ale jak nie istnieją jak istnieją bo je widać i zajmują pare kilo ??? :roll: )---może dociągnołem jakiegoś porypanego rpm-a i system idizie mówiąc kolokwialnie..... w las ???
pcAsterixos
 
Posty: 10
Punkty reputacji: 0

Postprzez marusmk » 21 wrz 2007, 20:12

pcAsterixos napisał(a):...input_file: Permission denied: >/mnt/hdb6/...
xine: found input plugin

Czyli wtyczkę znalazł ale problem jest z prawami dostępu.
Wklej zawartość pliku /etc/fstab to zobaczymy czy jest OK.
Ostatecznym Service Packiem dla windowsa będzie Linux.
marusmk
 
Posty: 865
Lokalizacja: Międzyrzecz
Dystrybucja: PCLINUXOS
Środowisko graficzne: KDE
Punkty reputacji: 2

Postprzez pcAsterixos » 21 wrz 2007, 20:21

mój plik: etc/fstab
none /proc proc defaults 0 0
none /dev/pts devpts mode=0620 0 0
none /proc/bus/usb usbfs defaults 0 0

# cdrom: CRD-8322B
# /dev/hda /mnt/cdrom auto user,exec,ro,noauto 0 0

# /dev/hdb2, size=17591175, type=131: Journalised FS: ext3 (primary)
/dev/hdb2 /home ext3 defaults 1 2

# /dev/hdb3, size=3550365, type=130: Linux swap (primary)
/dev/hdb3 swap swap defaults 0 0

# /dev/hdb4, size=19518975, type=131: Journalised FS: ext3 (primary)
/dev/hdb4 / ext3 defaults 1 1

# /dev/hdb5, size=19534914, type=11: FAT32 (extended)
/dev/hdb5 /mnt/win_c vfat user,exec,rw,noauto,iocharset=utf8,umask=0 0 0

# /dev/hdb6, size=19534977, type=131: Journalised FS: ext3 (extended)
/dev/hdb6 /mnt/hdb6 ext3 user,exec,rw,noauto 0 0

# /dev/hdc1, size=13976487, type=7: NTFS (primary)
/dev/hdc1 /mnt/win_d ntfs user,exec,ro,noauto,nls=utf8,umask=0 0 0

# /dev/hdc5, size=12980457, type=11: FAT32 (extended)
/dev/hdc5 /mnt/win_e vfat user,exec,rw,noauto,iocharset=utf8,umask=0 0 0

# /dev/hdc6, size=12964392, type=7: NTFS (extended)
/dev/hdc6 /mnt/win_f ntfs user,exec,ro,noauto,nls=utf8,umask=0 0 0
pcAsterixos
 
Posty: 10
Punkty reputacji: 0

Postprzez marusmk » 21 wrz 2007, 20:47

Fstab wygląda na prawidłowy, a co będzie jak zmienisz uprawnienia do tego pliku lub katalogu w którym on jest (jako root oczywiście).
Ostatecznym Service Packiem dla windowsa będzie Linux.
marusmk
 
Posty: 865
Lokalizacja: Międzyrzecz
Dystrybucja: PCLINUXOS
Środowisko graficzne: KDE
Punkty reputacji: 2

Postprzez pcAsterixos » 22 wrz 2007, 10:42

hehe ......no to sie wyjaśniło :oops: po prostu nie miałem uprawnień na nowo utworzonym koncie....a wcześniej oglądałem owszem ale mi sie pokićkało i na pewno oglądałem z konta roota :roll:
info dla takich jak ja :
zalogowałem sie jako root po czym wszedłem na partycje gdzie mam ten film i inne pliki otworzyłem tools-->open terminal po czym wpisałem :
chown -Rv krzysiek:krzysiek *

i wtedy zostały automatycznie dla całej zawartości partycji nadane prawa dostępu dla konta krzysiek.

(na podstawiepostu lupusa)

no i filmy mi działają
pcAsterixos
 
Posty: 10
Punkty reputacji: 0


Powrót do Oprogramowanie

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników i 1 gość